昨年自作したRyzen7+X570のPCにて、Windowsが起動不能になってしまった話

  |   2020/12/05 ( 2020/12/13 ) | 300 views
 0

ニアです。。。

残念なことに、昨年に自作したRyzen7+X570のPCが昨夜に突然電源が落ちて起動不能になってしまいました。

Nia-TN-SDfs-sweet.png
仕事で使っているWindowsノートPCやMacじゃなかったのが不幸中の幸いです。

1. 自作PCの今の状態

  • BIOSは起動する(ただ、ちょっと不安定でフリーズしたり、BIOS設定画面に入れなかったりすることがある)
  • Windowsは起動不能(マザーボードのメーカーのロゴ画面から進まない)
  • Windowsをクリーンインストールしようとも、インストーラーが起動しない
  • USBメモリから起動できるLinuxを入れたUSBメモリを接続しても、そのLinuxが起動しない
  • 電源ユニットの電源スイッチを入れると、マザーボードの通電ランプとイルミネーション部分が一瞬点灯する(本来だと通電ランプだけ常時点灯するはず)
  • 一部のケースファンのイルミネーションで、ノイズが入ったような光り方をする(これは多分、アドレサブルRGBケーブルの接触不良の可能性かな)
Nia-TN-SDfs-surprised.png
多分、ソフトウェア上の不具合ではなさそうです。。。

2. 試したこと

2.1. メモリ、グラフィックボード、SATA接続のSSD、HDD、BDドライブのを再接続して確認

まずは、メモリやストレージ、グラフィックボードなどが接触不良になっていないか確認しつつ、念のため再接続してみました。

HDD1台とグラフィックボードの電源ケーブルが抜けかかっていたので、しっかりと再接続しました。

2.2. CMOSクリアやBIOSアップデートをしてみる

マザーボード(ASRock X570 Taichi)にCMOSクリアボタンがあるので、それを押して設定情報をクリアしつつ、BIOSを最新バージョンにアップデートしてみました。

2.3. 放電してみる

長時間電源に接続していたので、もしかするとPCパーツが帯電しているのではと思い、電源をオフにし、電源ユニットやディスプレイのケーブルを外して、しばらく放置してみました。

その後BIOSを再設定し、Windowsのインストーラーを入れたUSBメモリを接続して起動したら、Windowsのインストール画面が出て、無事に再インストールすることができました。

データはリセットされてしまうけど、土日にじっくりセットアップし直そう・・・と思いきや、電源がまた落ちて、再びWindowsが起動不能になりました。

Nia-TN-SDfs-sweet.png
電源が落ちる寸前、デバイスの接続と接続解除の効果音が断続的に鳴っていました。。。
電源供給の問題なのかな・・・

2.4. HDDだけ接続せずに起動を試みるも・・・

電源ユニットの電力不足を疑い、HDDだけ接続せずに、起動を試みました。

しかし、全然改善せず・・・、それだけでなく、BIOS画面がフリーズしたり、BIOSの設定画面に入れなかったりすることもありました。

2.5. あと考えられるもの

  • CMOS用の電池交換
  • 電源ユニットを750W→850Wのものに交換(今のパーツ構成では、ちょっと電力不足な気がするので)

これくらいかな?
どうも電源とマザーボード周りが怪しいと私は推測します。

これでもダメだったら、Ryzenをアンインストールして、Intelを入れようと思います。

3. おわりに

この自作PCはプライベートでしか使っておらず、幸いにも、ほとんどのデータは外付けSSDやHDD、OneDrive、別のノートPCにバックアップをとっていたので、データ喪失は免れたのですが、あまりにも突然の出来事でしたので、今でもショックを隠せず。。。

こうなってしまったら仕方がない、電源ユニットを交換してもダメだった時のために、IntelのCPUに変える場合のパーツ構成を、スキマ時間にて計画しようと思います。

それでは、See you!

4.【12/9追記】電源ユニットを交換したけど、改善されず

先日に850Wの新しい電源ユニット(Seasonic FOCUS-GM-850)を購入し、入れ替えました。

マザーボードへ供給される+12V電源の電圧は12Vを少し上回るようになりましたが、Windowsはインストールメディアも含めて起動せず。。。

電源ユニット交換前
電源ユニット交換後
Nia-TN-SDfs-panic.png
ウゾダドンドコドーン!

そこで試しにMemTest86を使って、メモリのテストをしてみたところ、なんと大量のエラーが検出されていました。そりゃWindowsが起動しない訳さ。。。

Nia-TN-SDfs-sweet.png
スロットを入れ替えたり、メモリ1枚のみ入れたりしてみたけど、結果は同じでした。
多分マザボ、CPU、メモリのいずれか1つ以上の故障っぽいです

という訳で先日の計画通り、IntelのCPUベースで構成し直すことにしました。

この記事をシェアする
Chronoir.netのRSSフィードを購読する